Debian 9 support

General discussion of OpenCATS

Moderators: RussH, cptr13

Forum rules
Just remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but keep comments directed to the topic at hand.
Post Reply
rob_grimm
Posts: 1
Joined: 17 Nov 2017, 14:20
what is two(2) plus three(3) ?: 5

Debian 9 support

Post by rob_grimm » 17 Nov 2017, 14:24

Has anyone tried installing on Debian 9 yet?

php5 has been deprecated. php7 is the only option. I started to do an install and have a failure in the install wizard verifying the php_mysql interface is working.

Anyone else try this? Is there a patch I can apply? Or shall I change code to add php7 support?

Thanks for any thoughts,
rwm

User avatar
cptr13
Posts: 411
Joined: 23 Apr 2008, 01:53
what is two(2) plus three(3) ?: 5
Location: Mobile, AL
Contact:

Re: Debian 9 support

Post by cptr13 » 17 Nov 2017, 14:26

Opencats does not support php 7 yet. You would have to downgrade php on your system to php 5.6. No coded changes required.
I believe there are ways to run them side by side, but I'm not sure how of the top of my head.

User avatar
RussH
Site Admin
Posts: 781
Joined: 12 Apr 2008, 08:28
what is two(2) plus three(3) ?: 5
Location: UK
Contact:

Re: Debian 9 support

Post by RussH » 11 Dec 2017, 10:44

RussH

Report your issues and feature requests;
https://github.com/opencats/opencats/issues

Please CLICK THE TICK to accept the answer!

Post Reply