Help! Failed attempt to clone a live site

All Support requests here - with appropriate info
see http://opencats.org/wiki/index.php?title=Diagnostics

Moderators: RussH, cptr13

Forum rules
Just please remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but respect our space and keep your comments directed to the topic at hand.

Help! Failed attempt to clone a live site

Postby kevinharper » 11 Oct 2017, 15:05

I wanted to clone our live OpenCATS installation to test future updates and customizations, but I ended up with a fatal error, and now our live installation is down. Can someone tell me what I did wrong, or if my server configuration got messed up somehow?

I used SSH to copy the files from the entire folder to a new folder:

cp -fr sourcefoldername destinationfoldername

Then I went into the MySQL database, exported the entire thing, created a new one, and imported the SQL file. There were no errors, everything executed perfectly.

I then went into the new folder and changed the config file database settings to point to the new one.

Sometime around this time, we noticed the live site being down. Host is Dreamhost.

There is a 500 error on the root of the site: "Internal Server Error - the server encountered an internal error...."

And a Fatal Error on the careers portal: "Fatal error: Can't inherit abstract function awComponent::drawEnvelope() (previously declared abstract in finalize) in /path/to/Component.class.php on line 19."

Any help identifying what went wrong is appreciated. Dreamhost just says to restore from backup, but we'll lose about 4 hours of applicants. Not a lot, but I'd like to avoid if possible—and I'm not even convinced restoring will work, if the problem is how Dreamhost maps their MySQL to subdomains. It seemed sketchy to me while setting it up, and I'm concerned that that is what caused this error.
--Kevin

Kevin Harper
www.resultsinternet.com
208-249-8893
User avatar
kevinharper
 
Posts: 18
Joined: 15 Sep 2017, 22:17
Location: Idaho

Re: Help! Failed attempt to clone a live site

Postby kevinharper » 11 Oct 2017, 19:51

Update:

Dreamhost found a zend_extension line in the .htaccess that somehow got added to the site, maybe by employee testing things. This line was deleted and both the original site and cloned site now work.
--Kevin

Kevin Harper
www.resultsinternet.com
208-249-8893
User avatar
kevinharper
 
Posts: 18
Joined: 15 Sep 2017, 22:17
Location: Idaho

Re: Help! Failed attempt to clone a live site

Postby RussH » 11 Dec 2017, 11:52

Thanks Kevin..

that would have taken an age to find!

checking .htaccess would be one of the last things I'd check.. especially if I was just cloning a live site.
RussH

Report your issues and feature requests;
https://github.com/opencats/opencats/issues

Review OLD Feature Requests here... somewhat deprecated now.
http://opencats.uservoice.com
User avatar
RussH
Site Admin
 
Posts: 695
Joined: 12 Apr 2008, 08:28
Location: UK


Return to Cries for Help!

Who is online

Users browsing this forum: No registered users and 2 guests