Page 1 of 1

Antiword on a shared Unix host

Posted: 01 Nov 2008, 01:33
by arts99

I am running cats under a shared hosting account and asked my hosting provider to install antiword for me. They have kindly installed it for me but it does not seem to be working.

Initially I was getting the following error message:

Antiword binary /usr/bin/antiword is not executable (permissions: 0750).

so they sorted that and now this message comes:

Antiword binary failed to convert a DOC file to text properly (Should have returned 'This is a test document', returned '').

When I upload a word document to check i get this message:The file has been successfully attached, but CATS was unable to index the resume keywords to make the document searchable. The file format may be unsupported by CATS.

The hosting provider says that antiword has been installed correctly but he does not know what to do.

Can anyone help please?

Thank you

Re: Antiword on a shared Unix host

Posted: 06 Nov 2008, 22:56
by RussH

I'd check the config file to ensure CATS is looking in the right place for it;
Code: Select all
/* Text parser settings. Remember to use double backslashes (\) to represent
 * one backslash (\). On Windows, installing in C:\antiword\ is
 * recomended, in which case you should set ANTIWORD_PATH (below) to
 * 'C:\\antiword\\antiword.exe'. Windows Antiword will have problems locating
 * mapping files if you install it anywhere but C:\antiword\.
define('ANTIWORD_PATH', "/usr/bin/antiword");
define('ANTIWORD_MAP', '8859-1.txt');

Also - i fyou have a shell logon to your hosting account, try using antiword from a commandline and see if it's successful from there, as well

Re: Antiword on a shared Unix host

Posted: 12 Nov 2008, 23:59
by UNV Jerime
I Have a Solution For You

I own a hosting company called Universal Net Visions
and we host people with opencats and the opencats is up and running great

We also have personal standing by to do the install, setup and upgrade for you

you can reach me throught email at , My msn is or visite our site and get my cell number
off the contact s page and well handle it from there

Thank you
Universal Net Visions
Todays Visions For Tomorrows Future
Owner and CEO
Jerime Olmstead

Re: Antiword on a shared Unix host

Posted: 13 Nov 2008, 14:07
by xtremebassist
Your problem is that Antiword is installed but not properly. I ran into this problem myself. I compiled Antiword on a CentOS system and I could run it from the command line with no problems. When I tried the CATS installation, I came across the same error. So I went out and found a binary RPM release and installed it. Then the CATS installation went fine. The strangest thing was I have also previously compiled Antiword on a Slackware system (my own) and it works perfectly! Trying the same steps on a CentOS distro generated the same problems that you are experiencing.

Try to see if your hosting provider can find a binary installation of Antiword. If not, I was able to work with Jermie of Universal Net Visions to configure his hosting server to not only have Antiword installed and working correctly with CATS, but also PDFToText, HTML2Text and UnRTF. My client now has fully functioning, low hosting cost solution for CATS.

Re: Antiword on a shared Unix host

Posted: 08 Jan 2009, 12:42
by dcubasoy
Could you share all Centos 5 compiled Antiword,PDFToText, HTML2Text and UnRTF.


Re: Antiword on a shared Unix host

Posted: 08 Jan 2009, 13:27
by RussH
I think from memory that they're pretty much in the standard repositories - i'm guessing you want to know where they are? I've got the rpm names as I have them installed on my centos 5.x system.


I don't think I currently have pdf2text installed - but will rectify that shortly!

Re: Antiword on a shared Unix host

Posted: 26 Aug 2009, 16:57
by tonnic
I use hostpapa and they don't install things...would a compiled binary work for me if I found one?... if so, can someone send me them?.