OpenCATS 0.9.4-3

Free, Open-Source Applicant Tracking System including job-board. Entirely customisable!

Please describe the issue you're having
If you accept the answer, please mark the topic as [SOLVED] by clicking the tick.

Moderators: RussH, cptr13

Forum rules: Just please remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but respect our space and keep your comments directed to the topic at hand.
By Karol3509
I run my little database on my laptop. . . it has been having issues for the last 7-10days.

"Error Connecting to Database

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond."

Is the current error. Prior to Today it would do this but when I would try again it would give me the login screen, then every other time I did anything it would give this same error. I am really tired of having to key in things 2 and 3 times to get them to stay. :-(

the original install was in February, I took a break from using it in June and July . . . Not sure if that's relevant - I turn off apache and mysql when I am not using the database. I always start it FIRST before starting any other programs as it doesn't like if Skype jumps on one of it's ports.

I am not sure if this is a space issue or something is broken. I am very computer (unsavvy). Thanks!
User avatar
By RussH

Okay, possibly it's due to space or database errors. Hard to tell.

can you see if you've run out of space? Also anything in the error log. It may be that the database has some errors due to frequent shutdowns - the error log should report database errors when the mysql server starts up.

Certainly it's not a complex app so we should be able to identify the issue and fix it!
By Karol3509
I do know that I am low on space. I am actually trying to get the computer CLEAN (working with MBAM support as I type) so I can move files OFF of it (trying to avoid moving corrupted stuff and compounding issues) . . . I was wondering if I should move the opencats to a scandisk but am not sure how to do that if it even is a good idea.

I don't see error messages popping up in opencats other than the one I indicated.
Not sure where to look. BUT feeling better that you are confident we can fix this! THANKS!
By Karol3509
I just re-read your previous post - when it starts up there are NO errors. . . when I go to load it through my browser (Chrome - and I am not changing it) . . . it says it can't connect, IF I hit it AGAIN sometimes it WILL connect. BUT when I select anything - jobs/candidates/lists, anything it give sme the can't connect error again, BUT if I hit "refresh" on the browser it goes where I asked it to go . . . BUT the next time I click to go somewhere it does the SAME thing and I have to hit refresh to go there. it is WEIRD! I hope this helps you help me! :D

I REALLY appreciate the help!
User avatar
By RussH
Hi Karol,

sorry the errors will be in the log directory. Unfortunately you need to know where it's logging MySQL and APACHE errors. Assuming you are running WAMP then it'll write here to a file called error.log
Apache in WAMPServer writes errors to the C:\wamp\logs folder or C:\wamp64\logs if you are using the 64bit version, as does MYSQL and PHP
By Karol3509
YICKS! THat is so foreign to me. I was going by it not giving me any errors on start up. I will see if I can do a find for those you mentioned and let you know. I am also working with MBAM to remove malware and such still.
By Karol3509
Ok I didn't find it doing a search and then realized you might mean in the program itself! DUH! :roll:

I tried just pasting them in but they were TOO BIG. Then I tried saving them and then attaching BUT I get the following error:

Invalid file extension: Apache-Error-Logs-Aug10.txt

FYI- it doesn't matter WHAT they are saved as it always says invalid file extension. . . and sometimes they save as .log and STILL same error.

By Karol3509
OK. I freed up a bunch of space . . . I noticed the following:
1:36:06 PM [main] Initializing Control Panel
1:36:06 PM [main] Windows Version: Home 64-bit
1:36:06 PM [main] XAMPP Version: 5.6.28
1:36:06 PM [main] Control Panel Version: 3.2.2 [ Compiled: Nov 12th 2015 ]
1:36:06 PM [main] You are not running with administrator rights! This will work for
1:36:06 PM [main] most application stuff but whenever you do something with services
1:36:06 PM [main] there will be a security dialogue or things will break! So think
1:36:06 PM [main] about running this application with administrator rights!
1:36:06 PM [main] XAMPP Installation Directory: "c:\xampp\"
1:36:06 PM [main] Checking for prerequisites
1:36:16 PM [main] All prerequisites found
1:36:16 PM [main] Initializing Modules
1:36:16 PM [main] Starting Check-Timer
1:36:16 PM [main] Control Panel Ready
2:06:14 PM [Apache] Status change detected: running
2:06:17 PM [mysql] Status change detected: running
3:08:37 PM [Apache] Status change detected: stopped
3:08:37 PM [Apache] Error: Apache shutdown unexpectedly.
3:08:37 PM [Apache] This may be due to a blocked port, missing dependencies,
3:08:37 PM [Apache] improper privileges, a crash, or a shutdown by another method.
3:08:37 PM [Apache] Press the Logs button to view error logs and check
3:08:37 PM [Apache] the Windows Event Viewer for more clues
3:08:37 PM [Apache] If you need more help, copy and post this
3:08:37 PM [Apache] entire log window on the forums
3:08:40 PM [mysql] Status change detected: stopped
3:08:40 PM [mysql] Error: MySQL shutdown unexpectedly.
3:08:40 PM [mysql] This may be due to a blocked port, missing dependencies,
3:08:40 PM [mysql] improper privileges, a crash, or a shutdown by another method.
3:08:40 PM [mysql] Press the Logs button to view error logs and check
3:08:40 PM [mysql] the Windows Event Viewer for more clues
3:08:40 PM [mysql] If you need more help, copy and post this
3:08:40 PM [mysql] entire log window on the forums
7:33:51 PM [Apache] Status change detected: running
7:34:00 PM [mysql] Status change detected: running

--there were several icons for this in my tray and I closed them all to start over, skype is running so I think that is why the port issues, I have found that I need to have database up FIRST then skype (VOIP). . .
By Karol3509
I am still having the SAME error I originally asked about. Please advise. Thanks!

Is it possible to move my entire database to a different computer? I may have to upgrade in the future.
User avatar
By RussH

hadn't replied as I'm not entirely sure how to repair a crashed MySQL db on WAMP. But please follow the directions here which look the same as on Linux; ... ble-errors

Once it's up and running, it's easy to back-up and move to another machine.. however you'd want to fix it first before you move it.
Email Setting!!!-Solved

OpenCats dev are never been clear in thier answers[…]

Job Order Export

Hi RussH, any chance of getting a reply about thi[…]

Unable to edit Candidates

I have have freshly installed openCATS have set my[…]

How to install OpenCats on hostinger?

I have PHP 5.6 and I uploaded the OpenCats folder […]

how to "delete" a user

Thanks for the reply The thread op asked about de[…]

Email Integration

Hey CFM, all, this is the code I had created to […]

Yes it is possible. But you have to dug into the s[…]

It need to be exceptionally truthful to export the[…]

hey plz reply fast