OpenCATS 0.9.4-3

Free, Open-Source Applicant Tracking System including job-board. Entirely customisable!

Please describe the issue you're having
If you accept the answer, please mark the topic as [SOLVED] by clicking the tick.

Moderators: RussH, cptr13

Forum rules: Just please remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but respect our space and keep your comments directed to the topic at hand.
By Karol3509
I'm experiencing difficulty with the opencats database I am using. It is hosted on the same machine I am using to access it yet it keeps timing out, if I refresh then it will load properly MOST of the time, BUT if I enter notes or have it up more than a few seconds when I hit enter it times out and I lose what I just wrote.

I have developed a work around - copying everything I write before I post it so that when it times out, I can paste it in instead of rewriting it and risking losing content. Sometimes it takes 2 or 3 times to put the note in before it STAYS in. Chronic Timing out.

This makes it VERY difficult/frustrating to get a good call rhythm going.

This is the error message
Error Connecting to Database

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

I had this problem prior and was told to do the following:

mysqlcheck --check --auto-repair --all-databases
mysqlcheck --optimize --all-databases

..then restart mysql
I have tried THIS - SEVERAL times and the issue persists. To be transparent I did back up the old database, create a NEW instance on a NEW computer and then migrate the data over. the issue was FIXED prior to backup but started misbehaving a few days after install (when I started using it).

I have over 700 records. . . I am getting ready to do important 1,000 more . . . I'd like to have the issues solved before I do the import.

Please let me know if you need anything to help diagnose the issue. THANK YOU!
User avatar
By RussH

sorry about this, it really doesn't sound like an application issue, more a server one. Are you running on windows? I've heard that sometimes you need to give explicit windows firewall permission to allow the MySQL port to work (port 3306). Maybe you can disable the windows firewall temporarily and see if the connectivity issue is resolved?
By Karol3509
Yes Sir I am running on windows. I am not sure how to deal with a firewall. But I know that I have to open the database stuff BEFORE I open anything else like skype b/c skype steals the ports that OpenCATS needs!

I'll have to see about the firewall situation and get back to you.
By Karol3509
Oddly . . . it is on that port.

OK I had a friend help me get to the fire wall. . . it appears that I can't change any settings for mysqld . . .
port3306.jpg (308.71 KiB) Viewed 801 times
troubleshoot.jpg (233.01 KiB) Viewed 801 times
As you can see from the screenshot above . . .

I went into the Firewall program . . .slid down to something that resembled MySQL . . . (mysqld) then clicked on "details" which brought up the window "edit an app" from there I selected "network types" which caused "Choose Network Types" window to pop up. . . as you can see "Private" is selected AND both "Private" and "Public" are grayed out!

I can't understand how a firewall can even be a concern given that the computer I am using to access the database is the very computer the database resides on. . . I don't need internet to use my database. . . Could it be a problem with Google Chrome as the browser? If that could be it, is it possible to use TWO browsers at the same time? b/c everything I do for work is in Google Chrome and that can't change (if I could change it I would but it's not a decision I can make).

I appreciate all the help you can give me! Thank you!!
Last edited by Karol3509 on 01 Dec 2018, 00:13, edited 1 time in total.
By Karol3509
OK I am supposed to be starting a new campaign for a new client MONDAY - I have to import 700 people into this database of mine that is STILL Giving me FITS! it keeps timing out, it literally lives on the SAME machine I am using and I can't understand why it times out, I was always able to update notes and such in the system when I was actually using the internet and it was housed somewhere else (I moved out on my own this year and no longer use that same opencats database I am referring to and CANNOT)

Here's the error I am getting -
Untitled.png (22.4 KiB) Viewed 753 times
Thanks in advance for trying to help . . . I am starting to wonder if I just need to just buy another database program . . .I just don't want to deal with fancy stuff . . .I like the simplicity of open cats!
User avatar
By RussH

sorry meant to reply after your last post.

Okay, the issue doesn't seem to be with opencats but rather with windows. That's fine - so for the firewall, you probably have some options greyed out as you're not logging in with an administrator account. Can you log back in to windows using an account with administrator rights and try again/ the options then shouldn't be greyed out.
By Karol3509
my account runs with administrator rights, AND I can't see how a firewall can be a problem when I am accessing it from the same machine.

the URL in the browser is literally" http://localhost/KATS/KATS/index.php?m=home"

can you help me to understand why it is timing out? 0.06 seconds doesn't seem like a long time, is there a way to adjust the length of time somewhere in opencats??

By Karol3509
I should also mention that I DID make the changes to mysqld (public and private) checked, AND tested things out, I am STILL having the timing out issue. This is ultra frustrating, I'm just not sure what is causing the issue or what to do about it.

I did reset back to just "private" for Mysqld as I am paranoid about protection.
Admin Login Page

Failed to load resource: the server responded with[…]

http error 500

While trying to open opencats/index.php? the page […]

What host? Did you use the documentation? What i[…]

custom fields

I created a simple text field during the job posti[…]

new version check

Thanks for the explanation.

ä / ü / ö in emails

Thank you. Thank you. I've inserted it. I'll get b[…]

Hi, sorry not heard of any Kubernetes deployment[…]

Candidate edit page date

Hi, we've just closed out the php 7.x feature bran[…]

For both your questions there's really a single an[…]

sorry I think this may possibly be a XAMPP / Win[…]