OpenCATS 0.9.4-3

Free, Open-Source Applicant Tracking System including job-board. Entirely customisable!

Please describe the issue you're having
If you accept the answer, please mark the topic as [SOLVED] by clicking the tick.

Moderators: RussH, cptr13

Forum rules: Just please remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but respect our space and keep your comments directed to the topic at hand.
#4912
Hi,
Good morning (10AM GMT)

I hope the team had a good Christmas break.

I came across OpenCats a little while ago and it seems like a great bit of kit. I am however yet to test it properly in a live environment, other than the demo.

I have been having some issues and problems with the OpenCats software for a short while now and have been trying to resolve it on my own and have come stuck. I receive a series of FATAL ERRORs, have repeatedly tried to install/uninstall the software and run the wizard, have changed the PHP versions accordingly:

Operating System Type: CATS thinks your operating system is UNIX.
PHP Version: 5.6.40
Database Version: MySQL 5.7.32-log

Fatal error: Class 'OpenCATS\UI\CandidateQuickActionMenu' not found in /OpenCats/modules/candidates/Show.tpl on line 56
This is line 56:
<?php TemplateUtility::printSingleQuickActionMenu(new CandidateQuickActionMenu(DATA_ITEM_CANDIDATE, $this->data['candidateID'], $_SESSION['CATS']->getAccessLevel('candidates.edit'))); ?>

Fatal error: Class 'OpenCATS\UI\QuickActionMenu' not found in /OpenCats/modules/companies/Show.tpl on line 31
This is line 31:
<?php TemplateUtility::printSingleQuickActionMenu(new QuickActionMenu(DATA_ITEM_COMPANY, $this->companyID, $_SESSION['CATS']->getAccessLevel('companies.edit'))); ?>

If this is something you can advise or guide on, it would be massively appreciated.
I am somewhat stuck and wanted to fix this myself if possible, however have been unable to do so.

Thank you in advance,
Kind regards,
Richard
Last edited by Richard IV on 06 Jan 2021, 10:33, edited 1 time in total.
#4923
In relation to the below...
I am able to install OpenCATS and use the _INSTALL, however I for some reason am unable to load dependencies and use composer. Basically, I seem to get stuck at the "SSH and Run Composer" stage.
I've tried a variety of options via ftp, putty, etc, although am somewhat stuck...
:?: :| :o :shock:
#4924
Hi Richard,

firstly - sorry for the slow response! (Happy New Year!)

Secondly I'd seriously use PHP 7.2 and deploy the pre-release version which will become release shortly https://github.com/opencats/opencats/releases

FInally - compser. Definitely required to pick up the dependencies for the moment until I push a release with all the dependencies included. There shouldn't be an issue running this - but if you're on shared hosting there may be some restrictions on what you can do.

If you can redo this with the most recent release then ping me when you get stuck.. we'll sort it out.
#4926
Hi Russ,
Hope you had a good Xmas and a Happy New Year to you too

Firstly: No real apology needed for the delay, the response and offer for assistance is massively appreciated

Secondly: I've followed the steps and deloyed the pre-release version with php 7.2, I can see the welcome screen but this is prior to running the composer

Finally: I'm almost certain its me missing something out or not doing something as required, I just can't seem to work out what it is at present.
> I've downloaded putty and have FTP/SSH access
> Have manually downloaded composer.phar
> https://packagist.org/ and transferred into the root project folder as it is within a sub-domain and specific folder.
> Have tried to run "php composer.phar install" and "require 'vendor/autoload.php';" along with all host of varying commands and can get nowhere

I get this in return:
"X-Powered-By: PHP/4.4.9
Content-type: text/html

<br />
<b>Parse error</b>: syntax error, unexpected T_STRING in <b>*************************/OpenCATS/composer.phar</b> on line <b>100</b><br />

Line 100 of Composer.phar consists of:
"namespace Composer\Autoload;"

I also found this article:
https://stackoverflow.com/questions/170 ... nd-via-ssh
None of which helped...

I'm hoping you can advise or guide me...
Thanks in advance

Stella outlook password recovery software for ps[…]

Stella outlook outlook ost to PST converter softw[…]

Stella offline edb-to-pst conversion software ca[…]

I recently migrated my OpenCATS from a local Ubunt[…]

Thank you Russ. I was wondering if people had foun[…]