OpenCATS 0.9.4-3

Free, Open-Source Applicant Tracking System including job-board. Entirely customisable!

Please describe the issue you're having
If you accept the answer, please mark the topic as [SOLVED] by clicking the tick.

Moderators: RussH, cptr13

Forum rules: Just please remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but respect our space and keep your comments directed to the topic at hand.
Hi Charles,

I'm new here, but I've just done a clean install of OpenCATS on Linux and I got my bulk import to work, so perhaps I can help?

You don't select a bunch of files to import from the mass upload screen, you have to move the files to a specific location for upload.

Go to your install directory, where your running OpenCATS lives. Under Ubuntu mine is at /var/www/cats/ (I followed the install guide and this is a symlink to the actual directory at opencats0.91a)

You'll find a directory called /upload/massimport/ (I may have this slightly wrong - I'm not at my box, but the directory is obvious once you look into your install directory.)

Move the CV's there and you can then go to candidates - add - mass import. The number of resumes found will be listed and you'll have several options on dealing with them.

I did change the permissions on the directory so that any user can copy files there, as on my install at least, you had to be root to do so.

Please note that there is no resume parsing, but the added resumes are searchable.

I hope this helps,

Hi All,

not sure anyone can advise me. I am running OpenCats 0.9.4 and have a number of CVs in various formats, .pdf, .doc, .docx, etc, that I would like to import. I log in as an Admin, so I would have thought this would be enough permissions, but when I copy CVs to the /upload/massimport folder, the CVs are not imported in. Have tried it with just .doc files, and then .pdf, but none of them work.

Any idea what I am doing wrong?

Hope someone can help.



sorry for this,

it seems to be an intermittent issue and from what I've seen only appears if you're installing under Windows?

Can you review the resolution details below in the similar reported issues and confirm if the actions resolves your problem?

If these all fail, can you open it as a new issue in githb and we can work through it.
Hi RussH,

tried this links you posted, but they do not help solve the issue.

I even installed OpenCATS on Xamp (Windows 7 machine), to see if I could get it to work, but I still get the same issues.

The pdf files I place in the \Upload\Import are seen by OpenCATS, and it seems to go through the process of uploading them, but then it gives the error message "None of the files you uploaded were able to be imported!"

Anything else I can try?

Thanks for your help.


Mass import.. do you have the resume indexing tools installed? i.e. pdf2txt, etc etc
Managed to fire up an Ubuntu VM and install/configure Opencats and found that I am able to import .docx files, but have issues with other formats.

As a non-linux user, so of the documentation for installing Opencats on Ubuntu 16.04 is not quite correct, specifically the section when creating users and databases in the MariaDB section. Had to remove the ' from the section 'opencats'.* which worked.

Russ, Good morning and thank you for checking on[…]

Autofill option

let me test on a local install.. works on the prod[…]

Upgrade to PHP 7.3

So.. we're at 7.2 at the moment, there is at least[…]

Security issues

Okay, so this is a wiki entry for restricting file[…]

Hello! Thanks ementalist! This fixed my upgrade […]

Resume scoring

Hi, sorry this isn't available within opencats

Bulk Activity Logging

Hi, this is both easy and hard to do... There'[…]