OpenCATS 0.9.4-3

Free, Open-Source Applicant Tracking System including job-board. Entirely customisable!

Please describe the issue you're having
If you accept the answer, please mark the topic as [SOLVED] by clicking the tick.

Moderators: RussH, cptr13

Forum rules: Just please remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but respect our space and keep your comments directed to the topic at hand.
Hello everyone,
I have been installing OpenCATS onto a RHEL server with everything loading into Linux just fine. But when I start the actual OpenCats installation, when I get to the CATS installation test, I get:

Cannot connect to database
Access denied for user 'cats'@'localhost' (using password: YES)

Using phpMyAdmin I checked and the cats user is created. One curiosity: In the OpenCATS documentation the instructions to create the user from the command line gave me a syntax error. Also, the documentation says to create user: 'opencats' but the installation test seems to be checking for user: 'cats.' The instructions also indicate 'databasepassword' which I used when I created the user and password in phpMyAdmin. I have tried every combination of user 'opencats' and user 'cats' along with the 'databasepassword' no password, and anything else I could think of.

I am pretty stuck here. Thank you in advance for your help and guidance.
I think I found it.

I am having hte same issue attempting to get 9.4 installed and running.

In the Config.php there is a section that looks like this:
/* Database configuration. */
define('DATABASE_USER', 'cats');
define('DATABASE_PASS', 'password');
define('DATABASE_HOST', 'localhost');
define('DATABASE_NAME', 'cats_dev');

Note that the username, password and db name are set to values completely different than the instructions. I believe you just need to change these to the values that we were given:

/* Database configuration. */
define('DATABASE_USER', 'opencats');
define('DATABASE_PASS', 'opencats');
define('DATABASE_HOST', 'localhost');
define('DATABASE_NAME', 'opencats');

I am going to test it next - I have to re-upgrade as I backed out when I could not get past the same issue.

Hope this helps.
Hi Gregg.

when you manually create a database and user in MySQL, you need to specify that in the installation wizard. Please report back if you have further problems!
Can't find indexing tools

I am a windows user I was installing openCATS but[…]

I have something similar. Could someone assist ple[…]

Hello, I did not see any options to change Company[…]

Creating Customized Modules

Hi , I'm looking for documentation to understand h[…]

Dev branch myql compqatibility

Oh, it works with mariadb? Thanks, I'll try it out[…]

I'm not the OP, but I had a dependency issue, I di[…]

Other Hosting Options?

For the record, Docker works just fine.

Email Configuration

during installation of opencats, i selected smtp a[…]