Page 1 of 1

How I upgraded - phew!!!

Posted: 15 May 2008, 08:51
by montievv
Older version - CATS Version 0.7.1 (Sutlej)
Upgrade to - 0.9.x

Tried the web based upgrade. Gave me a blank index page after final step. :? Tried a couple of times again. Am not a hacker/programmer, but realized :idea: it must be those custom fields which were causing the problem. Deleted all the custom fields using phpmyadmin - yep crazy me did it on a production machine cause I wasnt allotted any more machines where I work. Still didnt work. This was exhausting. :cry:

a couple of cigarettes & tea later...
1) deleted everything (had a backup).
2) reinstalled older version of cats.
3) Installed newer version alongside.
4) moded my older database and added newer fields, indexes and deleted everything old in it.
5) pointed newer cats installation to use older database.
6) WORKED!!!!!!!! :D

Lessons in Stupidity
DONT FIX IT IF IT AINT BROKE - Still feeling on top of the world after the successful database mod, I thought to myself (over another cigarette) "shouldnt I reinstall my OS after all the OS modules, Xorg I have added removed over a period of time?". The left side (devil) said "do it. do it." and the right said otherwise. I could have just reinstalled over the existing system but i realized that over the years i had never done an rm -rf /*. That would be an exciting thing to do. So I go ahead with a rm -rf /*

I install my fav distro (same version & CD as the previous one). Install older cats with the database - WORKING (Gods were still happy with me). Try modding the database as I did earlier (4 hours work) - and it never worked after that. Tried 3 times more on different days with a fresher mind... but this has never worked.

I cant promise much. But whoever can help me out with this gets free beer shipped to him/her. :)

Re: How I upgraded - phew!!!

Posted: 21 Mar 2015, 12:15
by billgate123
I created this procedure that creates number of questions each with 10 options. I hope it is helpful to others :).