OpenCATS 0.9.4-3

Free, Open-Source Applicant Tracking System including job-board. Entirely customisable!

General discussion of OpenCATS

Moderators: RussH, cptr13

Forum rules: Just remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but keep comments directed to the topic at hand.
By sri
#4938
I have installed opencats (CATS Version 0.9.3 Inferno) in a new server with php 7.3. When I tried to run ATS, it is showing error "CATS Error: All required PHP extensions are not loaded.". It is running fine when deployed in php 5.3. How can i run opencats with latest version of php. Please help
User avatar
By manuel
#4945
Opencats has a minimum supported PHP version of PHP 5.5, and are working towards full PHP 7 compatibility.
By aarong
#5011
Russ,

Hello! We are being force migrated to PHP 7.3 (ready or not, here it comes) in our shared hosting environment. It looks like they will sunset PHP 5 in the next few weeks. Is there a timeline when 7.3 may be supported? I know there has been a ton of work to move to 7.x but I need to hatch a plan if I can't get the curves to cross.

Thanks a million!

Aaron
User avatar
By RussH
#5017
So.. we're at 7.2 at the moment, there is at least one 7.3 patch proposed - but I'd rather step back and see where the bugs are in the 7.2 implementation first!
#5128
hi there, Im being forced to upgrade my php version at least at 7.0... Im currently using openCats 0.9.4 which doesn not support it, but I saw there is a new release of 0.9.6 which supports till 7.2.

my question is how to proceed to this upgrade, is there any guide to follow or can you give me some instructions in order to try ir in a dev environment before proceeding?

thanks in advance
User avatar
By RussH
#5134
Hi there,

you should be able to do an in-place upgrade. However I'd take a backup of your active running instance (software & database) and do a test upgrade on a test box first. Once you're happy it works, do it on your production box. Note that only PHP 7.2 is supported - still not 7.3 compatible!!!!

so once you have your instance available - just unpack the 0.9.6 tar.gz or zip file into a new directory (e.g. /var/www/html/opencats-0.9.6), REMOVE THE INSTALL_BLOCK directory, then navigate to the directory to run the install wizard. Provide your existing db username & password & choose to upgrade the detected installation.

Report here or on github if you have any issues!
By damarsan
#5157
Hi there, me again. Sorry to ask the same question, but the hosting which im using is no longer supporting old PHP versions. They are able now to use PHP 7.3, 7,4 and 8.0... is there any ETA to get opencats runnning in any of them?
Hosting / Development

If anyone is looking for a cost effective hostin[…]

ost 2019 converter software

Stella the ost converter software that converts […]

Stella exchange edb converter 2019 software is a[…]

ost to pst converter software

Try stella ost to pst open source software to co[…]

HI - at the moment we only test against PHP 7.2. M[…]

new / unread candidates

Hi! :) Does anyone know a quick way to show a lis[…]

Email Integration

Hi! hope you're well! I'm new to the forum & t[…]

I just connected LibreOffice Base to my CATS datab[…]

Hi, just wondering if this feature already exists?[…]