Please describe the issue you're having
If you accept the answer, please mark the topic as [SOLVED] by clicking the tick.

Moderators: RussH, cptr13

Forum rules: Just please remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but respect our space and keep your comments directed to the topic at hand.
User avatar
By zoomiest
I installed the new 0.9.7 and it went flawlessly. Wonderful.
However, as I go through normal commands to restore my data, I get new errors.
When I google my error it says that I have the SQL command wrong (?)

$ sudo mysql -u cats -p -f -D cats < dbackup.sql

but, I get:
ERROR 1064 (42000) at line 616: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '' Current\n * Online Marketer at Indipendente (Sole Proprietorship...' at line 1

It looks like it hit some data, it didn't like and it coughed.

Have you seen anything like this before?
Is this a version mismatch from my database and a new version of MariaDB?
Did that bracket in my data throw off MariadB?
Even the -f switch is not letting me skip errors

Environment: Ubuntu server 22.04.2 LTS
MariaDB 15.1
The error notice indicates that there is a syntax problem in your SQL dump file (dbackup.sql) around line 616. There appears to be a SQL data string that is either formatted incorrectly or contains unexpected characters.

Here are several recommendations to resolve this matter:

Verify the SQL dump file:
Access the dbackup.sql file and locate line 616. Analyze the SQL command or data in the vicinity of that line to detect any syntax problems or atypical characters. Revise or amend the problematic portion.

Quotation marks (' and ") and special characters should be carefully considered while dealing with your data. Make sure that they are adequately encoded if necessary. Syntax errors can occur when quotations or special characters are mishandled.

Database Version Compatibility: Ensure that the version of MariaDB you are utilizing is compatible with the SQL dump. Although slight variations in versions may not result in problems, significant version updates can bring about modifications in syntax. Make sure that you are importing the dump into a compatible version of MariaDB.

Great news about v0.9.7.4 being released on GitHub[…]

I encountered the same error. In my case, it was d[…]

Thank you for sharing the installation resources f[…]

Today, I'd like to introduce you to a game that I'[…]