Please describe the issue you're having
If you accept the answer, please mark the topic as [SOLVED] by clicking the tick.

Moderators: RussH, cptr13

Forum rules: Just please remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but respect our space and keep your comments directed to the topic at hand.
#5473
Hello,
I got an error message by testing the email configuration under administration-->Email Configuration-->Test Configuration.
An error occurred. geometry dash lite

Errors occurred while attempting to send mail to one or more provided addresses: daniels.fertl@gmx.de (): Could not instantiate mail function.

However, I didn't change anything on the code. How to solve this error?
Thanks in advance
#5474
HI there,

opencats uses phpmailer for emails. It's likely when you were offered which of three ways to send emails you may have chosen one your system doesn't support? Usually option 1 or 2 would not be supported under Windows.

You can change this at any time by amending the config.php file in webroot.

Choose the option you know you want to use;
Code: Select all
/* This setting configures the method used to send e-mail from CATS. CATS
 * can send e-mail via SMTP, PHP's built-in mail support, or via Sendmail.
 * 0 is recomended for Windows.
 *
 * 0: Disabled
 * 1: PHP Built-In Mail Support
 * 2: Sendmail
 * 3: SMTP
 */
define('MAIL_MAILER', 3);

/* Sendmail Settings. You don't need to worry about this unless MAIL_MAILER
 * is set to 2.
 */
define('MAIL_SENDMAIL_PATH', "/usr/sbin/sendmail");

/* SMTP Settings. You don't need to worry about this unless MAIL_MAILER is
 * set to 3. If your server requires authentication, set MAIL_SMTP_AUTH to
 * true and configure MAIL_SMTP_USER and MAIL_SMTP_PASS.
 */
define('MAIL_SMTP_HOST', "smtp.gmail.com");
define('MAIL_SMTP_PORT', 587);
define('MAIL_SMTP_AUTH', true);
define('MAIL_SMTP_USER', "me@email.com");
define('MAIL_SMTP_PASS', "notarealpassword");
//Options: '', 'ssl' or 'tls'
define('MAIL_SMTP_SECURE', "tls");

Great news about v0.9.7.4 being released on GitHub[…]

I encountered the same error. In my case, it was d[…]

Thank you for sharing the installation resources f[…]

Today, I'd like to introduce you to a game that I'[…]