Please describe the issue you're having
If you accept the answer, please mark the topic as [SOLVED] by clicking the tick.

Moderators: RussH, cptr13

Forum rules: Just please remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but respect our space and keep your comments directed to the topic at hand.
By manuel
#5489
Hi,

I'm planning to use a XML feed for presenting vacancies on the website.

When I use [domainname]/xml on a hosted server I get a Server 500 error.
Working on a local Xampp with PHP7.2.0 I get the following errors:

Warning: Use of undefined constant LEGACY_ROOT - assumed 'LEGACY_ROOT' (this will throw an Error in a future version of PHP) in C:\xampp\htdocs\Cats\xml\index.php on line 37

Warning: include_once(LEGACY_ROOT/lib/CATSUtility.php): failed to open stream: No such file or directory in C:\xampp\htdocs\Cats\xml\index.php on line 37

Warning: include_once(): Failed opening 'LEGACY_ROOT/lib/CATSUtility.php' for inclusion (include_path='C:\xampp\php\PEAR') in C:\xampp\htdocs\Cats\xml\index.php on line 37

Fatal error: Uncaught Error: Class 'CATSUtility' not found in C:\xampp\htdocs\Cats\xml\index.php:38 Stack trace: #0 {main} thrown in C:\xampp\htdocs\Cats\xml\index.php on line 38

I used the XML feed before with 0.9.2 version without any problems so I hope it's a small issue.

With kind regards,
Manuel
User avatar
By RussH
#5490
Hi Manuel,

yes it was broken and a very small fix. I've added this fix to the Github project https://github.com/opencats/OpenCATS/pull/636

If you want to apply this patch to your installation, all that's needed is to add this to /xml/index.php - after line 36
Code: Select all
chdir('..');                         <- EXISTING
include_once('config.php');          <- TO BE ADDED 
By manuel
#5495
Hello Russh,

I've added the code and everything works fine now.

When using and importing XML I got a Greater Than Sign after the cityname.
I discoverd a small typo in "indeed.xptl"
At line 19
<city><![CDATA[$[jobCity]]]>></city> there is one Greater Than Sign to many just before </city>
It must be
<city><![CDATA[$[jobCity]]]></city>

Greetings
Manuel

Great news about v0.9.7.4 being released on GitHub[…]

I encountered the same error. In my case, it was d[…]

Thank you for sharing the installation resources f[…]

Today, I'd like to introduce you to a game that I'[…]