Please describe the issue you're having
If you accept the answer, please mark the topic as [SOLVED] by clicking the tick.

Moderators: RussH, cptr13

Forum rules: Just please remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but respect our space and keep your comments directed to the topic at hand.
#5587
Hi Team,

I am brand new to OpenCATS and I am trying to install the available version of OpenCATS-0.9.4-3 on Windows Server 2012 running PHP version 8.2.12. I have installed XAMPP and all other prerequisites. When I ran the installation wizard, I got lots of $data{0} errors that I fixed by changing it to $data[0]. Finally, I got to the page to start the installation but now I am stuck at the below error:
=====================================================================================================
PHP MySQL extension (mysql) is not loaded.
Check your settings in php.ini.

Under certain Linux / BSD distributions, the PHP MySQL extension is a separate package.

Debian: Run "apt-get install php5-mysql" and restart your webserver.

FreeBSD: Install the php5-mysql port, or configure MySQL support in the php-extensions port and restart your webserver.
=====================================================================================================
I tried loading the mysql extension in php.ini as extension=mysql and restarted the Apache service but the error is still there.

Looking for some immediate help friends.

Regards
#5588
Open the php.ini file:
This file is usually located in the php directory of your XAMPP installation, for example, C:\xampp\php\php.ini.
Enable MySQLi Extension:
Find and enable the MySQLi extension by removing the semicolon (;) at the beginning of the line:
;extension=mysqli
Change it to:
extension=mysqli
Restart Apache:
After saving the changes to php.ini, restart the Apache server from the XAMPP Control Panel to apply the changes.
To confirm that the MySQLi extension is loaded:
Create a PHP Info File:
Create a new file named phpinfo.php in your web directory (C:\xampp\htdocs\) with the following content:
<?php
phpinfo();
?>
Access the PHP Info Page:
Open a web browser and navigate to http://localhost/phpinfo.php.
Look for the mysqli section to verify that the MySQLi extension is enabled and loaded.
Additional Tips:
Check for Compatibility: Ensure that the version of OpenCATS you are using is compatible with PHP 8.2.12. Some older software may have compatibility issues with newer PHP versions.
Database Connection: Double-check your database connection settings in OpenCATS configuration files to ensure they match your MySQL server settings.
scratch geometry dash

Great news about v0.9.7.4 being released on GitHub[…]

I encountered the same error. In my case, it was d[…]

Thank you for sharing the installation resources f[…]

Today, I'd like to introduce you to a game that I'[…]