OpenCATS 0.9.4-3

Free, Open-Source Applicant Tracking System including job-board. Entirely customisable!

Please describe the issue you're having
If you accept the answer, please mark the topic as [SOLVED] by clicking the tick.

Moderators: RussH, cptr13

Forum rules: Just please remember to play nicely once you walk through the door. You can disagree with us, or any other commenters in this forum, but respect our space and keep your comments directed to the topic at hand.
By Dais3
#4669
First, thanks for a great piece of software!
I have installed the PHP7.x release over 9.4_full release on my QNAP NAS and pretty much everything is working nicely.
Couple of issues though.
Email won't send using SMTP - I suspect this is because the PHPMailer module is not updated to work on PHP 7.3 which I am running. I will try and update this manually - just wanted to check if anyone had any experience of this?
Secondly I really want to get Resume Indexing working. Am I understanding the process correctly that currently by default Opencats installs with Resume Parsing which is displayed in the box when a CV is uploaded, but for indexing I need to add further modules like antiword? Is there any guidance/documentation on how best to proceed with this?
many thanks
Dave
User avatar
By cptr13
#4670
Qnap...music to my ears. I've got a couple home nas's and love them. Having said that...I haven't played around with OpenCATS much. Though I'm overdue for some long promised documentation updates.

Don't worry about the antiword files and the others. I believe the resume parsing works without them. I'm not sure whether they can be installed on a qnap anyway, though you may check to see if they're in the entware packages. If so, it's a possibility. Never even thought to check that.
By Dais3
#4671
Yeah the QNAP is great - I'm on a TS453 :)
The search into the resumes seems ok - is that a full text search rather than indexed? Main problem is the parsing. docx parses perfectly, .doc is ok albeit a bunch of unwanted characters. However PDF parse just produces garbage - and it takes ages...
Yeah I was going to go Entware...
By Dais3
#4673
As an update to this I was able to use Entware to load the xpdf package to the QNAP NAS. Works perfectly. There is no Entware package for antiword or htmltotxt. I went so far as trying to load the gcc compiler package to compile antiword in situ but I couldn't get gcc loaded.

My work around has been to write some simple PHP to decode doc files and the html files. Its far from perfect, but does allow the resume to load and be viewed and searched so perfectly acceptable.

If anyone has had any joy getting antiword or the gcc compiler onto a QNAP NAS please do share :)

Otherwise all good now!
Thanks again for some great software!
Dave

I just encountered this myself. The issue was tha[…]

I gave up on that box, and tried again with Ubuntu[…]